No internet connection
  1. Home
  2. Support

Exporting as zip = 404, no zip file in wp uploads

By @mmbob2019-12-03 02:33:35.278Z

I'm a new user, so I may be missing something obvious.

I'm running this on a staging (dev) server, trying to generate a zip file, and I'm specifying the live site URL as my destination URL. The server doesn't have any particular restrictions or limitations - we have over 100 sites on it under development, and no oddities that we are aware of.

It crawls all the URLs, says it's done and the button to download the zip appears. I click it and get a 404. When I look on the staging server, the folder wp-static-html-output-1575339372 is empty.

I don't see any log content that indicates an error. If there was a memory limit issue would it be in the logs?

Permissions on the above folder appear to be normal (755, same as WP uploads, etc)

Any thoughts/suggestions?

  • 3 replies
  1. M
    @mmbob2019-12-12 22:17:08.730Z

    Anyone have any suggestions for us to try? Or another plugin that might work? Thanks!

    1. M
      In reply tommbob:
      @mmbob2020-01-11 01:48:49.379Z

      I have tried a few things but still unable to get this to work.

      Checked that PHP ZIP and CURL are enabled. Plenty of memory and it isn't timing out. No console errors, nothing weird in XHR. The last entry appears to be {my domain}/wp-content/uploads/WP2STATIC-CURRENT-ARCHIVE.txt?cacheBuster=1578707195803

      I attempted to load the Export log and it says "Requested log file not found". Does this mean nothing went wrong, or that this is somehow not functioning properly?

      A number of WP-STATIC files in "uploads" appear to have no file size:
      2nd crawl list
      crawled links
      discovered URLs log
      discovered URLs total (file contents is the number "0")
      final 2nd crawl list
      final crawl list

      other files do have size:
      initial crawl list
      initial crawl total
      modified crawl list
      progress
      current archive

      There's also an html-output-1578707069 folder with nothing in it.

      I tried removing & reinstalling the plugin - no change. Also deactivating other plugins and switching to a WordPress default theme - no change.

      I tried refreshing the uploads directory during the export progress. Initially the final crawl list has a size of 19k, the same as the initial crawl list. As the crawl progresses the size of this decreases until eventually at the end it is zero. Not sure if relevant but it's something.

      Does any of this suggest anything?

      1. M
        In reply tommbob:
        @mmbob2020-01-14 19:19:09.865Z

        I was able to get this to run locally and on the client's server. It never would run on our staging server though. Don't know why. Anyway, site has been converted, problem solved.