No internet connection
  1. Home
  2. Support

Export fails every time I try (I'm using PRO Version 6.2)

By Angel @marthaelax2019-01-11 05:08:15.937Z

I'm trying to export my website, but it always fails. The message says "An error has occurred, please consult the Help tab for where to get assistance."

I tried setting the crawl to 1, 10, Maximum, but always fails.

When I check the export log, there is nothing relevant there:
STARTING EXPORT: 2019-01-11 04:53:44
STARTING EXPORT: PHP VERSION 7.2.13
STARTING EXPORT: OS VERSION Linux dragon.servidoresph. com 3.10.0-714.10.2.lve1.5.15.el7.x86_64 #1 SMP Tue Mar 27 16:33:32 EDT 2018 x86_64
STARTING EXPORT: WP VERSION 5.0.3
STARTING EXPORT: WP URLhttps://chicstyle.club
STARTING EXPORT: WP SITEURLhttps://chicstyle.club
STARTING EXPORT: WP HOMEhttps://chicstyle.club
STARTING EXPORT: WP ADDRESShttps://chicstyle.club
STARTING EXPORT: PLUGIN VERSION 6.2
STARTING EXPORT: VIA WP-CLI?
STARTING EXPORT: STATIC EXPORT URLhttps://chicstyle.netlify.com/

When I check the Network tab on chrome, there is a 503 message

the console

Already increased the PHP max_execution_time from 90 to 3,600 and PHP memory_limit from 128 to 512, but still getting the same error.

  • 4 replies
  1. Leon Stafford @leonstafford2019-01-11 05:43:08.776Z

    Hi @marthaelax,

    Thanks for submitting the support request with lots of info, that helps.

    OK, so when we see a 500+ status from the server, there should be an accompanying error log in the web server/PHP logs.

    Could you please try to get those, too?

    I have a couple of fixes set for a new release that may be helpful for you, but want to do some more testing before making a new release.

    Cheers,

    Leon

    1. MAngel @marthaelax2019-01-11 05:57:42.418Z2019-01-11 06:05:54.794Z

      This is the only log that I can see on cPanel Metris > Error:

      Not sure how to access PHP logs.

      Some info about the host environment:

      1. Leon Stafford @leonstafford2019-01-11 13:43:53.702Z

        Hi @marthaelax,

        OK, we may need to turn on PHP logging for the webserver. Is your web hosting company's support OK? Probably easier to request that they turn it on for PHP/WordPress and show you where to find it.

        If they're not helpful, you can directly contact me with access credentials and I can take a look for you or help you migrate onto some better hosting.

        Cheers,

        Leon

        1. MAngel @marthaelax2019-01-11 17:43:22.495Z

          I'll contact my host provider so they can guide me for the PHP/WordPress logs.

          Also, I just tried doing it on a local installation using Local by Flywheel and I got the following errors (Crawl = 5)

          Even though there were some errors, the initial crawl was completed, but when trying to Deploy to Netlify, it failed again. Here is the new Export log:

          STARTING EXPORT: 2019-01-11 05:06:11
          STARTING EXPORT: PHP VERSION 7.2.9
          STARTING EXPORT: OS VERSION Linux 27f958cef870 4.9.93-boot2docker #1 SMP Thu Jul 19 18:29:50 UTC 2018 x86_64
          STARTING EXPORT: WP VERSION 5.0.3
          STARTING EXPORT: WP URL http://chicstyle.local
          STARTING EXPORT: WP SITEURL http://chicstyle.local
          STARTING EXPORT: WP HOME http://chicstyle.local
          STARTING EXPORT: WP ADDRESS http://chicstyle.local
          STARTING EXPORT: PLUGIN VERSION 6.2
          STARTING EXPORT: VIA WP-CLI?
          STARTING EXPORT: STATIC EXPORT URL https://chicstyle.netlify.com/
          SAVING URL: FILE IS EMPTY /wp-content/themes/bimber/css/buddypress-rtl.css
          SAVING URL: FILE IS EMPTY /wp-content/themes/bimber/css/buddypress.css
          SAVING URL: FILE IS EMPTY /wp-content/themes/bimber/style.css
          NETLIFY EXPORT ERROR
          GuzzleHttp\Exception\RequestException: cURL error 55: SSL_write() returned SYSCALL, errno = 32 (see http://curl.haxx.se/libcurl/c/libcurl-errors.html) in /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Handler/CurlFactory.php:192
          Stack trace:
          #0 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Handler/CurlFactory.php(155): GuzzleHttp\Handler\CurlFactory::createRejection(Object(GuzzleHttp\Handler\EasyHandle), Array)
          #1 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Handler/CurlFactory.php(108): GuzzleHttp\Handler\CurlFactory::finishError(Object(GuzzleHttp\Handler\CurlHandler), Object(GuzzleHttp\Handler\EasyHandle), Object(GuzzleHttp\Handler\CurlFactory))
          #2 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Handler/CurlHandler.php(49): GuzzleHttp\Handler\CurlFactory::finish(Object(GuzzleHttp\Handler\CurlHandler), Object(GuzzleHttp\Handler\EasyHandle), Object(GuzzleHttp\Handler\CurlFactory))
          #3 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Handler/Proxy.php(34): GuzzleHttp\Handler\CurlHandler->__invoke(Object(GuzzleHttp\Psr7\Request), Array)
          #4 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Handler/Proxy.php(57): GuzzleHttp\Handler\Proxy::GuzzleHttp\Handler{closure}(Object(GuzzleHttp\Psr7\Request), Array)
          #5 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/PrepareBodyMiddleware.php(72): GuzzleHttp\Handler\Proxy::GuzzleHttp\Handler{closure}(Object(GuzzleHttp\Psr7\Request), Array)
          #6 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Middleware.php(36): GuzzleHttp\PrepareBodyMiddleware->__invoke(Object(GuzzleHttp\Psr7\Request), Array)
          #7 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/RedirectMiddleware.php(76): GuzzleHttp\Middleware::GuzzleHttp{closure}(Object(GuzzleHttp\Psr7\Request), Array)
          #8 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Middleware.php(66): GuzzleHttp\RedirectMiddleware->__invoke(Object(GuzzleHttp\Psr7\Request), Array)
          #9 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/HandlerStack.php(73): GuzzleHttp\Middleware::GuzzleHttp{closure}(Object(GuzzleHttp\Psr7\Request), Array)
          #10 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Client.php(283): GuzzleHttp\HandlerStack->__invoke(Object(GuzzleHttp\Psr7\Request), Array)
          #11 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Client.php(131): GuzzleHttp\Client->transfer(Object(GuzzleHttp\Psr7\Request), Array)
          #12 /app/public/wp-content/plugins/static-html-output-plugin/library/GuzzleHttp/Client.php(137): GuzzleHttp\Client->requestAsync('POST', Object(GuzzleHttp\Psr7\Uri), Array)
          #13 /app/public/wp-content/plugins/static-html-output-plugin/powerpack/Netlify.php(85): GuzzleHttp\Client->request('POST', '/api/v1/sites/c...', Array)
          #14 /app/public/wp-content/plugins/static-html-output-plugin/powerpack/Netlify.php(39): StaticHtmlOutput_Netlify->deploy()
          #15 /app/public/wp-content/plugins/static-html-output-plugin/powerpack/Netlify.php(144): StaticHtmlOutput_Netlify->__construct()
          #16 /app/public/wp-content/plugins/static-html-output-plugin/library/StaticHtmlOutput/Dispatcher.php(84): require_once('/app/public/wp-...')
          #17 /app/public/wp-content/plugins/static-html-output-plugin/wp2static.php(17): require_once('/app/public/wp-...')
          #18 /app/public/wp-settings.php(322): include_once('/app/public/wp-...')
          #19 /app/public/wp-config.php(77): require_once('/app/public/wp-...')
          #20 /app/public/wp-load.php(37): require_once('/app/public/wp-...')
          #21 /app/public/wp-admin/admin-ajax.php(22): require_once('/app/public/wp-...')
          #22 {main}

          PS: First I tried with Crawl = Maximun on Local Installation, but initial crawl failed, then I changed the crawl to 5, but deploy to Netlify failed. The Netlify test setting says the connection is ok:

          I'm using a laptop (12 GB Ram and i7 6700 CPU)