No internet connection
  1. Home
  2. Support

Failed during "Crawling initial file list", please consult the Help tab for where to get assistance.

By K A @monetizer2019-04-23 13:23:10.131Z

Hi,
I am getting this error:
Failed during "Crawling initial file list", please consult the Help tab for where to get assistance.

How can I make it work, any troubleshooting guide?

Thanks

  • 13 replies
  1. Leon Stafford @leonstafford2019-04-23 16:29:31.595Z

    Hi @monetizer, can you please join me in our Slack group and I'll walk you through troubleshooting and resolving this error. It's usually server-related, ie a missing library or PHP memory limit that just needs a tweak for your first site/export:

    https://join.slack.com/t/wp2static/shared_invite/enQtNDQ4MDM4MjkwNjEwLTVmN2I2MmU4ODI2MWRkNzM4ZGU3YWU4ZGVhMzgwZTc1MDE2OGNmYTFhOGMwM2U0ZTVlYTljYmM2Yjk2ODJlOTk
    1. JJose Ignacio Zabaleta @JoseZabaleta2019-05-21 10:43:22.194Z

      Hi... I have the same problem... The memory limit is 128M... What is the memory limit required? How can I know if the error is due to missing library? Could it be due to incompatibility with a plugin? Thanke...

      1. Leon Stafford @leonstafford2019-05-22 07:11:02.786Z

        Hi @JoseZabaleta,

        Please try this early development build of version 7, it requires less system resources and has many fixes included:

        https://github.com/WP2Static/wp2static/releases/tag/7.0-build0002

        Cheers,

        Leon

        1. Leon Stafford @leonstafford2019-05-22 07:22:41.096Z

          Also, memory limit is impossible to know - too many variables with theme, plugin, server setup, size of content, complexity of source code it needs to parse, etc.

          The V7 preview I shared has had significant performance improvements made, so memory requirements should be a lot less.

          1. JJose Ignacio Zabaleta @JoseZabaleta2019-05-22 22:10:45.404Z

            Thanks... I have managed to install and activate the plugin in one of my sites and has generated a static site... but has not created the "wp-content" and "wp-includes" folders with the images, css, scripts...

            I installed the plugin in another of my sites, but I could not activate it:
            Error: The current version of PHP does not meet the minimum requirements of WP2Static.

            The php version of the site is 7.3

            Thanke...

            1. Leon Stafford @leonstafford2019-05-22 22:29:45.547Z

              Hi Jose, that should be minimum 7.0, thanks for spotting, will be fixed in next build!

              For the other, check your Processing settings for the "Rewrite URLs" and "Rename folders", there may be something set in there.

              1. Leon Stafford @leonstafford2019-05-22 22:33:26.861Z

                Hi @JoseZabaleta,

                What does the plugin tell you is the PHP version:

                Your current PHP version is: ???

                It may be that you have 7.3 installed, but not in use by the web server, only on the command line?

                I checked the code and it should only be complaining for versions lower than 7...

                Cheers,

                Leon

                1. JJose Ignacio Zabaleta @JoseZabaleta2019-05-23 19:50:00.103Z

                  Thanks Leon... I solved the problem with php and activated the plugin...

                  I have not touched the Processing settings... In any case, without having changed anything, now the plugin does create the wp-content and wp-includes folders...

                  Inside the folder wp-content is the plugins folder that contains ALL the plugins, including those that are disabled...

                  But inside the folder wp-content is not the themes folder... And that folder with the Divi folder inside is essential...

                  I can upload themes/Divi manually... What folders and files of Divi should I upload?

                  Thank you

                  1. Leon Stafford @leonstafford2019-05-25 19:52:42.994Z

                    Hi Jose,

                    Strange that no Divi files are being exported. I'd try a known server environment, like Local by FlyWheel to see if the problem persists, I'd guess it's something to do with the server environment, any errors about it shown in the Export Log / Log tab?

                    To manually copy the Divi files, I'd just grab the whole directory, minus any php files.

                    Cheers,

                    Leon

                    1. JJose Ignacio Zabaleta @JoseZabaleta2019-05-26 19:26:47.665Z

                      Hi Leon...

                      I do not know what server environment is... I do not know what Local by FlyWheel is... I do not see the Export Record tab but I do see the debug log tab and it's empty...

                      The plugin "a3 Lazy Load" does not work with WP2Static... Do you recommend any "Lazy Load" plugin that works?

                      Regardless of all the above, here you can see index.php of my site: https://www.solucionalacrisiseconomica.com/ And here you can see index.html generated by WP2Static: https://www.solucionalacrisiseconomica.com/index.html

                      As you can see, fonts do not work... As you can see in the bottom part, Divi does not work either... And if you try to share in social networks, you will see that the Monarch plugin does not work either...

                      Although I have uninstalled the Autoptimize plugin, the code generated by WP2Static is still all together, as you can see if you look at the source code...

                      Thanke...

                      1. JJose Ignacio Zabaleta @JoseZabaleta2019-05-27 21:05:34.967Z

                        Hi... I have tried other Lazy Load plugins and I have also created a html page manually... And I have verified that the lazy load code generated by the plugins does not work in html... That is, the same code that works in the php page, it does not work in the html version... Is there any way to implement lazy load in html? Thanke...

                        1. JJose Ignacio Zabaleta @JoseZabaleta2019-05-28 21:18:18.297Z

                          Hi... I think the reason why "Lazy Load" and Divi did not work is that the dns pointed to Cloudflare...

                          Now it works correctly: https://www.solucionalacrisiseconomica.com/index2.html

                          But WP2Static does not create all the necessary folders, such as themes... Attachment debug log...

                          Thanke...

                          debug.txt (39.23 kB)

          2. In reply toleonstafford:
            JJose Ignacio Zabaleta @JoseZabaleta2019-06-01 11:35:33.563Z

            Hi... I discovered that the Monarch plugin does not work in the static version created with https://github.com/WP2Static/wp2static/releases/tag/7.0-build0002 But it does work in the static version created with the current version of WP2Static

            Thanke...